The Qt library archive

Loading...

Home

KDELibs 4 Support

Porting aid from KDELibs4

Version:
5.39.0 (stable)released on 2017-10-14(older versions: 5.38.0, 5.37.0, 5.36.0, 5.35.0, 5.34.0, 5.33.0, 5.32.0, 5.32.0, 5.31.0, 5.30.0, 5.29.0, 5.28.0, 5.27.0, 5.26.0, 5.24.0, 5.23.0, 5.22.0, 5.21.0, 5.20.0, 5.19.0, 5.18.0, 5.17.0, 5.16.0, 5.15.0, 5.14.0, 5.13.0, 5.13.0, 5.10.0, 5.7.0, 5.6.0, 5.5.0, 5.4.0, 5.3.0, 5.2.0, 5.1.0, 5.0.0, 4.98.0)
License:
LGPLv2.1+
Platform:
Linux
Author:
The KDE Community
Topic:
Development
Home page:

This framework provides code and utilities to ease the transition from kdelibs 4 to KDE Frameworks 5. This includes CMake macros and C++ classes whose functionality has been replaced by code in CMake, Qt and other frameworks.

Code should aim to port away from this framework eventually. The API documentation of the classes in this framework and the notes at http://community.kde.org/Frameworks/Porting_Notes should help with this.

Note that some of the classes in this framework, especially KStandardDirs, may not work correctly unless any libraries and other software using the KDELibs 4 Support framework are installed to the same location as KDELibs4Support, although it may be sufficient to set the KDEDIRS environment variable correctly.


Read more


Packages